Автор Тема: Excel: Как создать последовательность слева направо?  (Прочитано 652 раз)

Оффлайн Bulat91

  • Посетитель форума
  • Сообщений: 5
Мне надо чтобы при автозаполнении ячейки заполнялись справа налево  =A1,=A2,=A3,=A4 и т.д., а не =A1,=B1,=C1...в ручную сделать не могу, так как речь идет о большом количестве. Короче, надо чтобы заполнилось так же, как и автозаполнение, которое вниз тянешь, но, чтобы я не делал, он все равно не заполняет, как мне надо. пытался делать =A1, =A2, =A3 и дальше тянуть последовательность, но он вставляет другую. Мне нужна последовательность ссылок.
P.S. на картинке не надписи, а формулы. (включен режим "показать формулы").


[вложение удалено администратором]

Оффлайн Администратор

  • Administrator
  • Сообщений: 1637
Эта формула будет делать то же, что A1, A2 и т.д.
=ИНДЕКС($A:$A;СТОЛБЕЦ()-1;1)

[вложение удалено администратором]

Оффлайн Bulat91

  • Посетитель форума
  • Сообщений: 5
Вот как тут растянуть чтобы было =A1,=A2,=A3...=A100? Когда его тянешь справа налево, он делает =D1,=D2,=D3,=G1,=G2,=G3...и т.д. Смотрите через "показать формулы".

[вложение удалено администратором]

Оффлайн Администратор

  • Administrator
  • Сообщений: 1637
смотрите файл

[вложение удалено администратором]

Оффлайн Bulat91

  • Посетитель форума
  • Сообщений: 5
Вот, смотрите, что мне надо сделать. Я скинул вам лист, в которой две таблицы. Первая называется "Выбор", вторая - "Трансфер". Мне надо расширить их до 100х100, сейчас она 30х30. Формулы не растягиваются, а ручную забивать квадрат из 1000 ячеек - просто ппц. Включите режим "показать формулы" и увидите принцип ссылок и поймете для чего мне надо именно так. (Ссылки в "трансфере" слева направо)

[вложение удалено администратором]

Оффлайн Администратор

  • Administrator
  • Сообщений: 1637
Можно сначала обсудить одну таблицу. Когда её разберём, то затем обсудить вторую таблицу. Иначе тяжело.
Какую таблицу вы хотите обсудить сначала?

Оффлайн Bulat91

  • Посетитель форума
  • Сообщений: 5
Мне надо вторую таблицу, потому что там ссылки не ставятся автозаполнением (посмотрите, они там идут слева направо с С77 по AF77 (это адреса), попробуйте растянуть их, например, до BB77(адрес), нарушается логическая последовательность, там становится AG59, а мне надо чтобы там было =C89.

Оффлайн Администратор

  • Administrator
  • Сообщений: 1637
Попробуйте такой вариант.
1. Выделите фрагмент "C77:AF106"
2. В строку формул вставьте эту формулу:
=ТРАНСП(C38:AF67)
3. Нажмите сочетание клавиш Ctrl+Shift+Enter
4. Готово. Проверьте, всё ли работает.

При работе с большим количеством формул используйте xlsb-формат. В этом формате формулы быстрее работают и файлы имеют меньший размер.

[вложение удалено администратором]

Оффлайн Bulat91

  • Посетитель форума
  • Сообщений: 5
Спасибо!