Автор Тема: Excel: Как прибавить время?  (Прочитано 300 раз)

Оффлайн lapin9126

  • Посетитель форума
  • Сообщений: 47
Excel: Как прибавить время?
« : 21 Декабрь 2016, 13:56 »
Здравствуйте. Приходят документы, в которых время прописано в формате "07:15:20:25", но на самом деле 7152025, просто применено форматирование ячейки 00\:00\:00\:00. Вопрос в следующем: как к этим данным прибавить время?

[вложение удалено администратором]

Оффлайн lapin9126

  • Посетитель форума
  • Сообщений: 47
Re: Excel: Как прибавить время?
« Ответ #1 : 21 Декабрь 2016, 16:53 »
Сам нашёл решение:
=ТЕКСТ(ТЕКСТ(B1;"00\:00\:00\,00")+ТЕКСТ($F$1;"00\:00\:00\,00");"[чч]:мм:сс:")&ПРАВБ(ТЕКСТ(ТЕКСТ(B1;"00\:00\:00\,00")+ТЕКСТ($F$1;"00\:00\:00\,00");"с,00");2)