Автор Тема: Excel Формулы: Значение по двум условиям.  (Прочитано 775 раз)

Vpslow

  • Гость
Имеются две таблицы, в них два значения по которым нужно искать сумму.
Если в таблице (Лист1) совпал БК (Лист1) и совпал счёт, то он должен вытянуть сумму.

[вложение удалено администратором]

Оффлайн Администратор

  • Administrator
  • Сообщений: 2017
Re: Excel Формулы: Значение по двум условиям.
« Ответ #1 : 24 Октябрь 2019, 12:33 »
Чтобы эта формула работала, в столбце C должны быть числа. Если будет текст, то формула не будет работать.
=СУММЕСЛИМН(Лист2!C:C;Лист2!A:A;A2;Лист2!E:E;B1)


Пояснение к формуле

В этой задаче суммировать не надо, поэтому не понятно, зачем используется функция "СУММЕСЛИМН".
Это связано с тем, что в экселе нет подходящей функции, которая могла бы искать по двум столбцам; в экселе все функции ищут только в одном столбце.

Поэтому это обходной способ - мы используем функцию не по назначению, но для нашей задачи она подходит, при условии, что нужно извлечь число.

Альтернативный вариант - использование формулы массива, но у него есть недостатки:
1) в большом количестве формулы массива могут тормозить работу с файлом;
2) в формуле массива нельзя указать столбец целиком, а нужно указать определённый фрагмент столбца, т.к. файл станет медленно работать или с ним вообще будет невозможно работать. Подразумеваются столбцы, которые участвуют в создании массива. Другие столбцы можно указывать целиком;
3) формулу массива надо вводить сочетанием клавиш Ctrl+End+Enter, что не удобно.

[вложение удалено администратором]