Автор Тема: Excel Формулы: Поиск по значению в массиве.  (Прочитано 103 раз)

Оффлайн vicm

  • Посетитель форума
  • Сообщений: 4
Есть массив данных, из него нужно отразить в соседней таблице только те строки, которые отвечают заданному условию.
Поиск строк с текущей либо будущей датой сверху вниз в таблице 1 и отражение без промежутков в таблице 2 без использования макросов.

[вложение удалено администратором]

Оффлайн Администратор

  • Administrator
  • Сообщений: 1637
Re: Excel Формулы: Поиск по значению в массиве.
« Ответ #1 : 11 Ноябрь 2018, 13:50 »
Столбец S допстолбец, в него записываются номера строк, в которых заданное условие.
В столбцах K:R формулы ссылаются на допстолбец S.
В столбце S формула массива - после записи формулы нажмите Ctrl+Shift+Enter, чтобы в строке формул появились фигурные скобки {}.
Формула в допстолбце S просматривает строки со 2 по 5 000.

Формула массива для допстолбца S:
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ($A$2:$A$5000>=СЕГОДНЯ();СТРОКА($A$2:$A$5000);"");СТРОКА(AAA1));"")

[вложение удалено администратором]

Оффлайн vicm

  • Посетитель форума
  • Сообщений: 4
Re: Excel Формулы: Поиск по значению в массиве.
« Ответ #2 : 11 Ноябрь 2018, 14:27 »
Спасибо большое за помощь, лучший форум.