Автор Тема: Excel: Пдстановка через впр и аналоги  (Прочитано 277 раз)

Оффлайн eman

  • Посетитель форума
  • Сообщений: 3
Приветствую.
Подскажите как можно подставить значения по аналогии с функцией ВПР только чтобы при ненайденных значениях вместо #Н/Д оставалась исходное значение в данной ячейке?  То есть чтобы не было замены.
Для чего? Нужно свести в 3 таблицы без замены ранее полученных результатов.
ПРИМЕР ЕСТЬ ВО ВЛОЖЕНИИ.



[вложение удалено администратором]

Оффлайн Администратор

  • Administrator
  • Сообщений: 1605
Re: Excel: Пдстановка через впр и аналоги
« Ответ #1 : 12 Январь 2018, 10:26 »
Нужно делать допстолбец и в него вставлять формулы. В столбце 2 нельзя сделать одновременно, чтобы в ячейке были и данные и формулы. Если вставить формулу, то не будет исходного значения. Если оставить исходные данные, то не будет формулы.

Оффлайн eman

  • Посетитель форума
  • Сообщений: 3
Re: Excel: Пдстановка через впр и аналоги
« Ответ #2 : 12 Январь 2018, 11:48 »
В этом и заключается проблема, как потом два столбца выделенных красным овалом на рисунке соединить воедино?

[вложение удалено администратором]

Оффлайн Администратор

  • Administrator
  • Сообщений: 1605
Re: Excel: Пдстановка через впр и аналоги
« Ответ #3 : 12 Январь 2018, 11:54 »
В столбце 2 не должно быть формул, должны быть только исходные данные.
В столбце 3 должны быть только формулы.

Формула для "C2":
=ЕСЛИОШИБКА(ВПР(A2;E:F;2;0);B2)

У вас на фотах режим формул R1C1, то такая формула для "C2":
=ЕСЛИОШИБКА(ВПР(RC[-2];C[2]:C[3];2;0);RC[-1])

Оффлайн eman

  • Посетитель форума
  • Сообщений: 3
Re: Excel: Пдстановка через впр и аналоги
« Ответ #4 : 12 Январь 2018, 11:57 »
Администратору спасибо за оперативность. Буду рекомендовать форум.