Автор Тема: Excel Формулы. Вычислить среднее значение нескольких чисел, если есть условие по одному столбцу.  (Прочитано 416 раз)

Оффлайн Посетитель 16.01.2022

  • Посетитель форума
  • Сообщений: 8
Задача заключается в том, что есть четыре столбца со значениями и нужно вычислить их среднее.
Нюанс заключается в том, что, если значение в третьем столбце больше 5, нужно его не учитывать в расчете среднего и вычислять среднее по трём столбцам.
Если значение в третьем столбце меньше 5, то нужно считать среднее по четырём столбцам.

[Вложение удалено]

Оффлайн Администратор

  • Administrator
  • Сообщений: 2066
Формула для первой строки:
=ЕСЛИ(C1<5;СРЗНАЧ(A1:D1);СРЗНАЧ(A1:B1;D1))

Оффлайн Посетитель 16.01.2022

  • Посетитель форума
  • Сообщений: 8