Автор Тема: Excel Формулы. Поиск номера строки по двум столбцам с помощью формулы.  (Прочитано 247 раз)

Оффлайн Посетитель 04.06.2021

  • Посетитель форума
  • Сообщений: 4
На листе заполнены два столбца: A, B.
В ячейку C1 нужно вставить формулу, которая бы находила строку, в которой в столбце A текст "Наименование 1", а в столбце B число 1.
Такое сочетание может быть только один раз.
Какая здесь нужна формула?

Оффлайн Администратор

  • Administrator
  • Сообщений: 2017
Формула массива. После записи формулы нажмите не Enter, а сочетание Ctrl+Shift+Enter, чтобы вокруг формулы появились фигурные скобки {}.
Формула просматривает 1000 строк. Большое количество строк для формул массива нельзя указывать, т.к. книга начнёт тормозить.

=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(($A$2:$A$1000="Наименование 1")*($B$2:$B$1000=1);СТРОКА($A$2:$A$1000);"");1);"не найдено")

Оффлайн Посетитель 04.06.2021

  • Посетитель форума
  • Сообщений: 4