Автор Тема: Excel: Сравнить 2 столбца данных и вывести результат из другой ячейки.  (Прочитано 63 раз)

Онлайн Vpslow

  • Посетитель форума
  • Сообщений: 10
Есть бизнесы-коды на листе 1, в столбце E и есть бизнес-коды на листе 2, в столбце BC.
Если бизнес-код из листа 2 есть на листе 1, то на лист 2, в эту строку, в столбец BB нужно записать код региона из листа 1, из столбца B.

Совпали бизнес-коды - код региона должен автоматически добавиться в соответствии с горизонталью.

Оффлайн Администратор

  • Administrator
  • Сообщений: 1710
Формула для BB2:
=ИНДЕКС(Лист1!B:B;ПОИСКПОЗ(BC2;Лист1!E:E;0);1)

Вместо "Лист1" укажите имя листа, которое у вас в файле. Если имя листа содержит пробел, то окружите имя листа одинарными кавычками:
=ИНДЕКС('Лист 1'!B:B;ПОИСКПОЗ(BC2;'Лист 1'!E:E;0);1)


Как работает формула

ПОИСКПОЗ ищет данные из столбца BC на листе "Лист1" в столбце E. Если найдено, то возвращает номер строки, где найдено.

ИНДЕКС извлекает данные из листа "Лист1", из столбца B из найденной строки.

Онлайн Vpslow

  • Посетитель форума
  • Сообщений: 10
Почему формула выдаёт #Н/Д?

Оффлайн Администратор

  • Administrator
  • Сообщений: 1710
Скопируйте данные из BC2, отобразите диалог "Найти и заменить", вставьте скопированный текст в поле "Найти", перейдите на лист1, выделите столбец E и ищите в нём данные. Если не найдено, значит в столбце E нет искомых данных и поэтому формула возвращает НД.

Онлайн Vpslow

  • Посетитель форума
  • Сообщений: 10
Помогло, действительно нет этих данных.
Спасибо большое!!!